Commit 0e40b8ee authored by Niklas Yann Wettengel's avatar Niklas Yann Wettengel

Trimmed the branch to only the homer_msgs sub directory

parent 1b6c00a2
## homer_msgs (kinetic) - 0.1.2-0
The packages in the `homer_msgs` repository were released into the `kinetic` distro by running `/usr/bin/bloom-release --rosdistro kinetic --track kinetic homer_msgs` on `Wed, 02 Nov 2016 13:33:39 -0000`
These packages were released:
- `homer_msgs`
- `homer_ptu_msgs`
Version of package(s) in repository `homer_msgs`:
- upstream repository: git@gitlab.uni-koblenz.de:robbie/homer_msgs.git
- release repository: git@gitlab.uni-koblenz.de:robbie/homer_msgs.git
- rosdistro version: `0.1.1-1`
- old version: `0.1.1-1`
- new version: `0.1.2-0`
Versions of tools used:
- bloom version: `0.5.23`
- catkin_pkg version: `0.2.10`
- rosdep version: `0.11.5`
- rosdistro version: `0.5.0`
- vcstools version: `0.1.39`
## homer_msgs (kinetic) - 0.1.1-1
The packages in the `homer_msgs` repository were released into the `kinetic` distro by running `/usr/bin/bloom-release --rosdistro kinetic --track kinetic homer_msgs --edit` on `Tue, 01 Nov 2016 12:54:29 -0000`
The `homer_msgs` package was released.
Version of package(s) in repository `homer_msgs`:
- upstream repository: git@gitlab.uni-koblenz.de:robbie/homer_msgs.git
- release repository: git@gitlab.uni-koblenz.de:robbie/homer_msgs.git
- rosdistro version: `0.1.1-0`
- old version: `0.1.1-0`
- new version: `0.1.1-1`
Versions of tools used:
- bloom version: `0.5.23`
- catkin_pkg version: `0.2.10`
- rosdep version: `0.11.5`
- rosdistro version: `0.5.0`
- vcstools version: `0.1.39`
## homer_msgs (kinetic) - 0.1.1-0
The packages in the `homer_msgs` repository were released into the `kinetic` distro by running `/usr/bin/bloom-release --rosdistro kinetic --track kinetic homer_msgs` on `Tue, 01 Nov 2016 12:13:07 -0000`
The `homer_msgs` package was released.
Version of package(s) in repository `homer_msgs`:
- upstream repository: git@gitlab.uni-koblenz.de:robbie/homer_msgs.git
- release repository: unknown
- rosdistro version: `null`
- old version: `null`
- new version: `0.1.1-0`
Versions of tools used:
- bloom version: `0.5.23`
- catkin_pkg version: `0.2.10`
- rosdep version: `0.11.5`
- rosdistro version: `0.4.7`
- vcstools version: `0.1.39`
# Package homer_msgs
This package contains messages and services which are used by different nodes in common.
The documentation for the message and services is contained by the message files itself.
# Package homer_msgs
This package contains messages and services which are used by different nodes in common.
The documentation for the message and services is contained by the message files itself.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Changelog for package homer_ptu_msgs
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
0.1.3 (2016-11-02)
------------------
* fix?
* Contributors: Niklas Yann Wettengel
0.1.2 (2016-11-02)
------------------
* added homer_ptu_msgs
* Contributors: Niklas Yann Wettengel
cmake_minimum_required(VERSION 2.8.3)
project(homer_ptu_msgs)
## Find catkin macros and libraries
## if COMPONENTS list like find_package(catkin REQUIRED COMPONENTS xyz)
## is used, also find other catkin packages
find_package(catkin REQUIRED COMPONENTS
roscpp
roslib
std_msgs
geometry_msgs
message_generation
)
## System dependencies are found with CMake's conventions
# find_package(Boost REQUIRED COMPONENTS system)
## Uncomment this if the package has a setup.py. This macro ensures
## modules and global scripts declared therein get installed
## See http://ros.org/doc/api/catkin/html/user_guide/setup_dot_py.html
# catkin_python_setup()
################################################
## Declare ROS messages, services and actions ##
################################################
## To declare and build messages, services or actions from within this
## package, follow these steps:
## * Let MSG_DEP_SET be the set of packages whose message types you use in
## your messages/services/actions (e.g. std_msgs, actionlib_msgs, ...).
## * In the file package.xml:
## * add a build_depend and a run_depend tag for each package in MSG_DEP_SET
## * If MSG_DEP_SET isn't empty the following dependencies might have been
## pulled in transitively but can be declared for certainty nonetheless:
## * add a build_depend tag for "message_generation"
## * add a run_depend tag for "message_runtime"
## * In this file (CMakeLists.txt):
## * add "message_generation" and every package in MSG_DEP_SET to
## find_package(catkin REQUIRED COMPONENTS ...)
## * add "message_runtime" and every package in MSG_DEP_SET to
## catkin_package(CATKIN_DEPENDS ...)
## * uncomment the add_*_files sections below as needed
## and list every .msg/.srv/.action file to be processed
## * uncomment the generate_messages entry below
## * add every package in MSG_DEP_SET to generate_messages(DEPENDENCIES ...)
## Generate messages in the 'msg' folder
add_message_files(
FILES
SetPanTilt.msg
CenterWorldPoint.msg
# Message2.msg
)
## Generate services in the 'srv' folder
add_service_files(
FILES
CenterWorldPointService.srv
)
## Generate actions in the 'action' folder
# add_action_files(
# FILES
# Action1.action
# Action2.action
# )
## Generate added messages and services with any dependencies listed here
generate_messages(
DEPENDENCIES
std_msgs
geometry_msgs
)
###################################
## catkin specific configuration ##
###################################
## The catkin_package macro generates cmake config files for your package
## Declare things to be passed to dependent projects
## INCLUDE_DIRS: uncomment this if you package contains header files
## LIBRARIES: libraries you create in this project that dependent projects also need
## CATKIN_DEPENDS: catkin_packages dependent projects also need
## DEPENDS: system dependencies of this project that dependent projects also need
catkin_package(
# INCLUDE_DIRS include
# LIBRARIES ptu
CATKIN_DEPENDS roscpp std_msgs geometry_msgs message_runtime
# DEPENDS system_lib
)
###########
## Build ##
###########
## Specify additional locations of header files
## Your package locations should be listed before other locations
# include_directories(include)
include_directories(
${catkin_INCLUDE_DIRS}
)
## Declare a cpp library
# add_library(ptu
# src/${PROJECT_NAME}/ptu.cpp
# )
## Declare a cpp executable
## Add cmake target dependencies of the executable/library
## as an example, message headers may need to be generated before nodes
## Specify libraries to link a library or executable target against
geometry_msgs/Vector3 point
bool permanent
float32 panAngle
float32 tiltAngle
bool absolute
<?xml version="1.0"?>
<package>
<name>homer_ptu_msgs</name>
<version>0.1.3</version>
<description>The ptu_msgs package</description>
<!-- One maintainer tag required, multiple allowed, one person per tag -->
<!-- Example: -->
<!-- <maintainer email="jane.doe@example.com">Jane Doe</maintainer> -->
<maintainer email="vseib@todo.todo">vseib</maintainer>
<!-- One license tag required, multiple allowed, one license per tag -->
<!-- Commonly used license strings: -->
<!-- BSD, MIT, Boost Software License, GPLv2, GPLv3, LGPLv2.1, LGPLv3 -->
<license>TODO</license>
<!-- Url tags are optional, but mutiple are allowed, one per tag -->
<!-- Optional attribute type can be: website, bugtracker, or repository -->
<!-- Example: -->
<!-- <url type="website">http://wiki.ros.org/ptu</url> -->
<!-- Author tags are optional, mutiple are allowed, one per tag -->
<!-- Authors do not have to be maintianers, but could be -->
<!-- Example: -->
<!-- <author email="jane.doe@example.com">Jane Doe</author> -->
<!-- The *_depend tags are used to specify dependencies -->
<!-- Dependencies can be catkin packages or system dependencies -->
<!-- Examples: -->
<!-- Use build_depend for packages you need at compile time: -->
<!-- <build_depend>message_generation</build_depend> -->
<!-- Use buildtool_depend for build tool packages: -->
<!-- <buildtool_depend>catkin</buildtool_depend> -->
<!-- Use run_depend for packages you need at runtime: -->
<!-- <run_depend>message_runtime</run_depend> -->
<!-- Use test_depend for packages you need only for testing: -->
<!-- <test_depend>gtest</test_depend> -->
<buildtool_depend>catkin</buildtool_depend>
<build_depend>message_generation</build_depend>
<run_depend>message_runtime</run_depend>
<run_depend>roscpp</run_depend>
<build_depend>roscpp</build_depend>
<run_depend>std_msgs</run_depend>
<build_depend>std_msgs</build_depend>
<build_depend>geometry_msgs</build_depend>
<run_depend>geometry_msgs</run_depend>
<!-- The export tag contains other, unspecified, tags -->
<export>
<!-- You can specify that this package is a metapackage here: -->
<!-- <metapackage/> -->
<!-- Other tools can request additional information be placed here -->
</export>
</package>
tracks:
kinetic:
actions:
- bloom-export-upstream :{vcs_local_uri} :{vcs_type} --tag :{release_tag} --display-uri
:{vcs_uri} --name :{name} --output-dir :{archive_dir_path}
- git-bloom-import-upstream :{archive_path} :{patches} --release-version :{version}
--replace
- git-bloom-generate -y rosrelease :{ros_distro} --source upstream -i :{release_inc}
- git-bloom-generate -y rosdebian --prefix release/:{ros_distro} :{ros_distro}
-i :{release_inc} --os-name ubuntu
- git-bloom-generate -y rosdebian --prefix release/:{ros_distro} :{ros_distro}
-i :{release_inc} --os-name debian --os-not-required
- git-bloom-generate -y rosrpm --prefix release/:{ros_distro} :{ros_distro} -i
:{release_inc}
devel_branch: master
last_version: 0.1.2
name: upstream
patches: null
release_inc: '0'
release_repo_url: git@gitlab.uni-koblenz.de:robbie/homer_msgs.git
release_tag: :{version}
ros_distro: kinetic
vcs_type: git
vcs_uri: git@gitlab.uni-koblenz.de:robbie/homer_msgs.git
version: :{auto}
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment